Installation and Setup Install Flutter and native IDEs

This lesson is available for PRO members or as a single course purchase. Sign-in and choose a plan below.


*Enrollment provides full access to this course (and updates) for life.

Or Signup for Unlimited PRO Access

Tasks

  1. Install Flutter and run flutter doctor.
  2. Add Flutter to your Path
  3. Download Android Studio and configure an Emulator.
  4. Download XCode (MacOS)

Dependencies

The current version of this course uses the following dependencies. For the most reliable results, you should use the same versions.

Flutter & Firebase regularly update these packages and later versions may break the code in this course, so update them at your own risk.

file_type_dartlang pubspec.yaml
dependencies:
  flutter:
    sdk: flutter

  cupertino_icons: ^0.1.2

  firebase_core: 0.4.4+3
  firebase_analytics: 5.0.11

  cloud_firestore: 0.13.4+2

  firebase_auth: 0.15.5+3
  google_sign_in: 4.4.1
  apple_sign_in: 0.1.0

  rxdart: 0.23.1
  provider: 4.0.5
  font_awesome_flutter: 8.8.1

Q&A Chat